Troubleshooting

From Gamepedia Help Wiki
Jump to: navigation, search

This guide will endeavor to catalog the most common issues experienced by wiki users, and some common solutions.

If you experience a problem not on this list or just need further help, please contact us.

General[edit | edit source]

Tips[edit | edit source]

When loading wiki pages, sometimes using url parameters can help with troubleshooting. They are invoked by appending ?<parameter> to the page url. Below are some useful parameters:
  • ?uselang=qqx: this loads the page with all the system messages exposed
  • ?useskin=hydra: this loads the page with the Hydra (light) skin.
  • Alternatively you can ?useskin=hydradark to load using the dark skin.
By default, a wiki's Search function only searches content pages. This excludes Template and other namespaces that may be relevant in your search. To include those namespaces, just click "Everything" on the search page, or click Advanced and choose the specific namespaces you're looking for.
  • Also note the search function only searches the content on the page that is actually rendered. To search the wikitext source of pages, use the parameter insource: in your query.

Automation/Bots[edit | edit source]

I'm having trouble logging in to AWB...
  • Please carefully follow Logging in to third-party tools. Especially note you need to be using HTTPS in the URL and your standard username/password will not work.
My bot is taking a long time to save pages.
  • Note that accounts with the bot flag still have a rate limit. To get around this you may be able to give your bot admin rights, as admins have no rate limits.
  • Aside from that you may be experiencing some delays based on AWB settings. Please make sure there is no delay set on the Bots tab.
  • Finally, there may be some issue on the server side. Try saving the pages in the browser directly. If you experience a slow save there, it may just be that there is a lot of data being updated on save - so you should try to reduce the size of any templates or Cargo/SMW data being saved with the page.

Extensions[edit | edit source]

Cargo[edit | edit source]

The results of the Cargo query show differently in the preview than they do on the actual page, despite no changes. How do I fix this?
  • Try purging the cache (More > Purge/Purge cache). This will cause the page contents to be re-built based on the current data in Cargo.
I'm getting duplicates in my queries, despite the fact they shouldn't exist. How do I resolve this?
  • This is a very common problem with Cargo. Generally, null editing the data page(s) as well as the query page will fix this.
  • After that, recreating the data table is the next step, although spamming the recreation of a table can also add to the problems.
  • Finally, you can also |group by= a unique parameter, generally _pageName, to help ameliorate the issue.

Files[edit | edit source]

I have an older file that shows 0 bytes even though it loads fine. How do I correct the file size listed?
  • Try re-uploading the file, that should cause the software to re-parse the file size and show correctly.